Email verification might not work for some users
Incident Report for Chatfuel
Resolved
This incident has been resolved.
Posted Nov 05, 2021 - 19:52 UTC
Investigating
We are aware that the verification email link is not being delivered to some users at the moment. Our team is already working on a fix.
Posted Nov 04, 2021 - 21:29 UTC
This incident affected: Dashboard.