Possible broadcasting delays
Incident Report for Chatfuel
Resolved
This incident has been resolved.
Posted Jun 14, 2022 - 03:06 UTC
Investigating
Our automated systems have detected that broadcast delivery may take longer than usual. We are currently investigating and will provide further updates as they become available.
Posted Jun 13, 2022 - 22:20 UTC
This incident affected: Re-engage.