Possible sequence triggering delays
Incident Report for Chatfuel
Resolved
This incident has been resolved.
Posted about 1 month ago. Mar 19, 2019 - 19:01 UTC
Investigating
Our automated systems have detected that sequence triggering may take longer than usual. We are currently investigating and will provide further updates as they become available.
Posted about 1 month ago. Mar 19, 2019 - 18:44 UTC
This incident affected: Broadcasts.