Possible broadcasting delays
Incident Report for Chatfuel
Resolved
This incident has been resolved.
Posted 2 months ago. Apr 14, 2019 - 11:50 UTC
Investigating
Our automated systems have detected that broadcast delivery may take longer than usual. We are currently investigating and will provide further updates as they become available.
Posted 2 months ago. Apr 14, 2019 - 11:38 UTC
This incident affected: Broadcasts.